System Requirements

Docusnap X & Docusnap X Server host system

Requirements for the computers on which Docusnap X or Docusnap X Server is installed:
Components
Requirements
Operating Systems

Windows 7 SP1
Windows 8, 8.1
Windows 10
Windows Server 2008 SP2
Windows Server 2008 R2 SP1
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016

RAM

min. 512 MB, recommended >= 2GB

CPU

>= 2 Cores

Resolution

min. 1024 x 768 Pixel
Recommended >= 1280 x 1024 Pixel

Resolution

min. 1024 x 768 Pixel
Recommended >= 1280 x 1024 Pixel

.NET Framework

Version >= 4.6.1

Windows Installer

Version >= 4.5

Database(s) *

SQL Server 2008 Express, Standard, Enterprise
SQL Server 2008 R2 Express, Standard, Enterprise
SQL Server 2012 Local-DB, Express, Standard, BI, Enterprise
SQL Server 2012 R2 Local-DB, Express, Standard, BI, Enterprise
SQL Server 2014 Local-DB, Express, Standard, BI, Enterprise
SQL Server 2016 Local-DB, Express, Standard, Enterprise

Microsoft Office **

Office >= 2007

* Docusnap is shipped with a Microsoft SQL 2014 Express LocalDB database.
** No external programs are required for generating documents.
To view the documents, you can use programs that support the following file formats: .docx, .xlsx, .html, .pdf, .odt, .vdx

Docusnap X Discovery Service host system

Requirements for the computers on which Docusnap Discovery Service is installed (without server or Docusnap client):
Components
Requirements
Operating Systems

Windows 7 SP1
Windows 8, 8.1
Windows 10
Windows Server 2008 SP2
Windows Server 2008 R2 SP1
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016

RAM

min. 512 MB, recommended >= 1GB

CPU

>= 2 Cores

Resolution

min. 1024 x 768 Pixel

.NET Framework

Version >= 4.6.1

Windows Installer

Version >= 4.5

Docusnap X Web host system

Components
Components
Requirements
Operating Systems

Windows 8, 8.1
Windows 10
Windows Server 2008 SP2
Windows Server 2008 R2 SP1
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016

RAM

min. 512 MB, recommended >= 2GB

.NET Framework

Version >= 4.6.1

Windows Installer

Version >= 4.5

Browser Requirements (Web & Plans)

Requirements for the browsers in order to run Docusnap Web:
Components
Requirements
Resolution

min. 1024 x 768 Pixel
Recommended >= 1280 x 1024 Pixel

Browser

IE >= 10
Edge >= 13
Google Chrome >= 31
Mozilla Firefox >= 45, Aurora >= 50.0, ESR >= 45.3
(https-Certificate must be manually in FF imported)
Opera >= 15

For documented devices (target systems)

Requirements for the browsers in order to run Docusnap Web:
Components
Requirements
Operating Systems

Windows NT (with WMI CORE 1.5 for Windows NT 4)
Windows XP
Windows Vista
Windows 7
Windows 8, 8.1
Windows 10
Windows Server NT (with WMI CORE 1.5 for Windows NT Server 4)
Windows Server 2000
Windows Server 2003
Windows Server 2008
Windows Server 2008 R2
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016
Linux (32 / 64 Bit) – SuSe
Linux (32 / 64 Bit) – RedHat
Linux (32 / 64 Bit) – Debian
Linux (32 / 64 Bit) – Kubuntu
Linux (32 / 64 Bit) – Ubuntu
Linux (32 / 64 Bit) – CentOS
HP-UX 11i v3
Mac OS X
IGEL Thin Clients (Windows & Linux, only UMS SQL-Server DB)

Network Protocols

WMI
LDAP (v.2)
SNMP Versions 1, 2, 3
SSH (RSA-Keys supported)

Exchange Server

Exchange Server 2003
Exchange Server 2007
Exchange Server 2010
Exchange Server 2013
Exchange Server 2016

SQL Server

SQL Server 2000
SQL Server 2005
SQL Server 2008 / R2
SQL Server 2012 / R2
SQL Server 2014
SQL Server 2016

VMware

vCenter 3.5, 4.0, 5.0, 6.0, 6.5
ESX Server 3.5, 4.0, 5.0, 5.5, 6.0
VMware Server

Windows Installer

Version >= 4.5

DHCP/DNS

only Windows based systems

Permission Analysis

For Windows systems or CIF / SMB-Emulations and Microsoft SharePoint installations and also Exchange 2007, 2012, 2013, 2016

Hyper-V

only Windows based systems

Veeam

Veeam Backup 8, 9, 9.5

Citrix XenCenter

XenServer 6, 7

Microsoft IIS

Version 6.0, 7.0, 7.5, 8.0, 8.5, 10

Microsoft SharePoint

SharePoint Server 2007, 2010, 2013
SharePoint Services 3.0
SharePoint Foundation

Backup Exec

Version 2010, 2012, 2014, 15

Oracle DBMS

Version 10g, 11g, 12c