Forum Installation Docusnap Server läuft, aber irgendwie läuft auch nicht (nicht konfiguriert)

Docusnap Server läuft, aber irgendwie läuft auch nicht (nicht konfiguriert)

Dieses Thema enthält 6 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Docusnap Support vor 1 Jahr, 1 Monat.

Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)
  • Teilnehmer
    Posts: 12

    Hallo,

    erstmal nochmals Danke für die Unterstützung schon in der Testphase, wirklich toll!

    Ich hänge nun an der Installation des Servers: laut Eventviewer und Dienste läuft der DocusnapServer,

    aber im Server Status innerhalb von Docusnap steht nur lapidar „nicht konfiguriert“ (bei Server und bei Status).

    Kann man irgendwo erkennen woran es nun gerade scheitert?

    Beste Grüße

    Klaus

    Keymaster
    Posts: 1581

    Guten Tag,

    den Docusnap Serverdienst können Sie in den Einstellungen unter dem Punkt Docusnap Server konfigurieren. Damit der Docusnap Serverdienst funktioniert, müssen folgende Punkte beachtet werden:

    – Identische Datenbankeinstellungen bei den Allgemeinen und Docusnap Server Optionen
    – Korrekte Server API Einstellungen bei den Allgemeinen und Docusnap Server Optionen (diese können Sie mit dem Verbindungstest Button überprüfen)

    Eine weitere Fehlerquelle kann die Authentifizierungsmethode bei der Datenbank sein. Falls Sie bei den Server Start Einstellungen keinen Benutzer eingetragen haben, wird der Docusnap Server mit dem lokalen Systemkonto gestartet. Wenn bei den Datenbankeinstellungen die Windows-Authentifizierung ausgewählt ist, versucht dieses lokale Systemkonto auf die Datenbank zuzugreifen. Da dieses Konto im Standard nicht im SQL Server hinterlegt ist, müsste dieses erst für die Datenbank berechtigt werden. Sie können dieses Problem aber einfach umgehen, indem Sie die Authentifizierungsmethode auf einen SQL Benutzer abändern.

    Sollte die Meldung immer noch angezeigt werden, nachdem Sie die Punkte überprüft haben, können Sie sich gerne bei unserem Service Desk (+49 8033 6978 4444) melden oder uns eine E-Mail an support@docusnap.com senden.

    Mit freundlichen Grüßen
    Ihr Docusnap Support Team

    Teilnehmer
    Posts: 12

    Hallo,

     

    >– Identische Datenbankeinstellungen bei den Allgemeinen und Docusnap Server Optionen

    Das war das Problem! Jetzt läufts. Danke für die schnelle Hilfe!

    Dennoch als Hinweis: Das Problemchen hat mich schlappe 3h gekostet.

    Wäre es nicht hilfreich eine Log-Datei erstellen zu lassen mit einer Fehlermeldung oder

    irgendwo zu erwähnen, dass man DIESSELBEN Einstellungen 2x machen muss?

    Das ist für mich als Laien nicht spontan denknotwendig ;-).

    Nichts für ungut!

    Klaus

     

     

    Keymaster
    Posts: 1581

    Hallo,

     

    vielen Dank für Ihr Feedback.

     

    Für die Installation haben wir bereits ein detailliertes Installation und Konfiguration-HowTo veröffentlicht, dass alle notwendigen Schritte beschreibt.

    Dies befindet sich im Bereich: Support -> Knowledge Base, ein passender Link hierfür ist:

    https://media.docusnap.com/media/doc/howto/DocusnapX_InstallationundKonfiguration.pdf

     

    Mit freundlichen Grüßen

    Ihr Docusnap Support

    Teilnehmer
    Posts: 12

    Hallo,

    steht da drin, daß man den Server 2x einstellen muss (also auch nochmals bei „Allgemeine Optionen“)?

    Ich hab’s nochmals nicht gefunden, aber wenn’s drin steht – sorry!

    Jetzt habe ich inzwischen Dokuscript – Dateien, aber diese werden nicht eingelesen  mit dem Hinweis

    „Kein gültigen DocusnapSkript-Dateien gefunden“ (Grammtikfehler ist nicht von mir ;-).

    Andere Baustelle:

    a) der SNMP-Scan erkennt nicht welche Switche wo/wie mit einanander verbunden sind (trotz SNMPv3),

    das löst man indem man die MAC-Adressen von Hand einträgt, ja?

    b) Nicht-managebare-Switche tauchen ja nirgends auf, diese legt man von Hand an (als Asset) denke ich.

    Wie macht man die am besten in der Topologie sichtbar?

     

    Beste Grüße

    Klaus

    Teilnehmer
    Posts: 12

    Hallo,

    also das Problem „“Kein gültigen DocusnapSkript-Dateien gefunden” ist schlicht ein Zugriffsfehler:

    Der Docusnap-Server kam nicht ins Verzeichnis rein.

    Keymaster
    Posts: 1581

    Hallo,

     

    vielen Dank für Ihre Rückmeldungen.

     

    Der Bereich „Allgemeine Optionen“ ist für die Konfiguration des Clients.

    Im HowTo wird im Punkt 3.1 auf die Konfiguration des Docusnap Clients eingegangen, im Punkt 3.2 wird die Docusnap Server Konfiguration durchgeführt.

     

    Zu Ihren SNMP-Punkten:

    Die Inventarisierung von Switchen per SNMP Scan liest unter anderem die Informationen über LLDP, CDP und Spanning Tree aus.

    Das Hauptaugenmerk liegt jedoch auf LLDP/CDP und wird höher bei der Auswertung der Informationen gewichtet. Trotzdem sind alle Informationen wichtig bei der Erkennung der gesamten Topologie.

    Ein wichtiger Knackpunkt bei der Darstellung vom Topologie Plan ist es, dass alle Switche von Docusnap inventarisiert werden müssen. Wenn natürlich Switche dabei sind, die nicht per SNMP erlernt wurden oder SNMP nicht beherrschen. Kann es vorkommen, das Docusnap die Beziehung nicht einzeichnen kann.

    Wichtig:

    Es gibt Switches die LLDP/CDP nur per Port aktivierbar sind, hierbei müssen alle Ports LLDP/CDP aktiviert haben, die mit anderen Switche verbunden sind, damit LLDP/CDP den Nachbar erkennen kann. Ein weiterer Punkt ist, dass manche Switche nur SNMP anfragen zulassen, die von registrierten IP Adressen stammen und somit den Scan blockieren.

     

    Ich würde Sie bitten, bezüglich Ihren SNMP-Punkten, ein Ticket, unter der Email Adresse support@docusnap.com, zu eröffnen, damit unser Team sich das Problem im Detail ansehen kann.

     

    Mit freundlichen Grüßen

    Ihr Docusnap Support

Ansicht von 7 Beiträgen - 1 bis 7 (von insgesamt 7)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.